Introducción

FileMenu Tools es un programa que permite personalizar el menú contextual que sale al hacer click con el botón derecho del ratón sobre cualquier archivo o carpeta desde el Explorador de Windows, desde Mi PC, o desde el Escritorio. Se pueden configurar los siguientes aspectos del menú contextual:

· Añadir varias utilidades incorporadas en el propio programa para manejar archivos y carpetas. Estas utilidades son las siguientes:
· Ejecutar con argumentos.
· Línea de comandos desde aquí.
· Copiar/Mover.
· Copiar ruta al protapapeles.
· Copiar el nombre al portapapeles.
· Copiar contenido al portapapeles.
· Pegar portapapeles.
· Atributos.
· Cambiar fecha.
· Dividir/Unir archivo.
· Registrar/Desregistrar DLL.
· Buscar o reemplazar.
· Renombrado masivo.
· Cambiar icono.
· Borrado extendido.
· Sincronizar dos carpetas.
· Eliminar archivos bloqueados.
· Eliminar sin usar la papelera.
· Destruir archivos.
· Crear una nueva carpeta.
· Tamaño de las carpetas.
· Añadir comandos personalizados que permiten ejecutar programas externos, copiar/mover los archivos a una determinada carpeta, o eliminar determinados tipos de archivos.
· Personalizar el submenú "Enviar a...", permitiendo añadir, eliminar y editar los programas de dicho menú.
· Habilitar/Deshabilitar los comandos que añaden otros programas al menú contextual.

La ventana de configuración de FileMenu Tools se muestra a continuación:

Con todas las características que proporciona FileMenu Tools se tiene una gran potencia para configurar completamente los comandos que aparecen en el menú contextual del Explorador de Windows.


 Comandos de FileMenu Tools

Comandos de FileMenu Tools

FileMenu Tools permite añadir comandos personalizados y varias utilidades incorporadas en la aplicación que permiten realizar distintas operaciones con archivos y carpetas. Estas utilidades son las siguientes:

· Ejecutar con argumentos.
· Línea de comandos desde aquí.
· Copiar/Mover.
· Copiar ruta al protapapeles.
· Copiar el nombre al portapapeles.
· Copiar contenido al portapapeles.
· Pegar portapapeles.
· Atributos.
· Cambiar fecha.
· Dividir/Unir archivo.
· Registrar/Desregistrar DLL.
· Buscar o reemplazar.
· Renombrado masivo.
· Cambiar icono.
· Borrado extendido.
· Sincronizar dos carpetas.
· Eliminar archivos bloqueados.
· Eliminar sin usar la papelera.
· Destruir archivos.
· Crear una nueva carpeta.
· Tamaño de las carpetas.

Desde la pestaña Comandos de FileMenu Tools de la ventana de configuración de FileMenu Tools se puede configurar los comandos personalizados y las utilidades que se mostrarán en el menú contextual. A la izquierda de cada elemento hay una casilla de verificación. Si esta casilla está marcada, el comando o la utilidad se mostrará en el menú contextual, en otro caso no se mostrará.

En el panel de acciones y en la barra de botones se dispone de las siguientes acciones:

· Agregar comando. Añade un nuevo comando personalizado. Las propiedades del comando se configuran desde el panel de propiedades.
· Agregar submenú. Añade un submenú al menú contextual. A los submenús se puede añadir elementos nuevos o existentes. Para mover elementos existentes dentro de un submenú hay que arrastrarlos con el puntero del ratón hacia el submenú. El texto y el icono que aparecerán en el submenú se configura desde el panel de propiedades. También se puede configurar el submenú para que cuando el submenú sólo contenga un comando, entonces se muestre ese comando en lugar del submenú. Esto se activa con la opción "Reemplazar si sólo un comando".
· Agregar separador. Agrega un nuevo separador.
· Eliminar. Quita el elemento seleccionado. Sólo se pueden quitar comandos personalizados, submenús y separadores. Los comandos incluidos dentro de FileMenu Tools no se pueden quitar; para deshabilitarlos hay que desactivar la casilla de verificación que se encuentra a la izquierda del elemento.
· Mover hacia arriba. Mueve el elemento seleccionado hacia arriba.
· Mover hacia abajo. Mueve el elemento seleccionado hacia abajo.


Ejecutar con argumentos

Esta utilidad ejecutará un programa pasándole los argumentos que se introducen a través de una ventana que se muestra previamente a la ejecución del programa.

Esta utilidad sólo se mostrará en el menú contextual para los archivos con extensión .exe, .dll o .bat.


Línea de comandos desde aquí

Esta utilidad abrirá una ventana de línea de comandos y se iniciará desde la carpeta seleccionada en el Explorador de Windows.

Esta utilidad sólo se muestra cuando se selecciona una carpeta.


Copiar/Mover

Esta utilidad permite copiar o mover a otra carpeta los archivos y carpetas seleccionados en el Explorador de Windows.

Muestra la siguiente ventana:

Para copiar o mover a una carpeta determinada, escriba la carpeta en el campo Carpeta de destino o seleccione la carpeta en el esplorador de carpetas.

Las carpetas que utilice más a menudo las puede añadir a una lista de Favoritos (para ello pulse el botón Añadir a Favoritos), y entonces se añadirá la carpeta seleccionada en el explorador de carpetas a la lista que hay tras la pestaña Favoritos. Para posteriormente poder elegir un favorito como carpeta de destino, seleccione la carpeta en la lista de favoritos.

Si un archivo que se va a copiar/mover existe en la carpeta de destino, por defecto se pregunta si se desea sobreescribir o no el archivo. Si desea que todos los archivos se sobreescriban sin que se pregunte, puede activar la opción Sobreescribir los archivos existentes.

Copiar o mover determinados archivos

Por defecto se copian recursivamente todos los archivos y carpetas seleccionados. Pero si lo desea, puede copiar o mover solamente algunos archivos y carpetas que cumplan unos determinados filtros. Desde la lista desplegable Archivos a copiar/mover se puede elegir entre tres opciones:

· Todos los archivos. Esta opción copiará o moverá recursivamente todos los archivos y carpetas.
· Sólo los que cumplan los filtros. Si se selecciona esta opción se copiarán o moverán solamente los archivos que cumplan los filtros que se indiquen en el campo Filtros.
· Todos los que cumplan los filtros. Si se selecciona esta opción se copiarán o moverán todos los archivos excepto aquellos que cumplan los filtros que se indiquen en el campo Filtros.

El campo Filtros debe contener una lista de filtros (cada uno separado por un punto y coma). Cada filtro puede contener los caracteres comodines * (cero o varios caracteres de cualquier tipo) o ? (un carácter de cualquier tipo). Por ejemplo, para que el filtro lo cumplan los archivos con extensión exe o con extensión dll, se tendría que utilizar el siguiente filtro: *.exe;*.dll.


Copiar ruta al portapapeles

Esta utilidad copia al portapapeles la ruta completa de todos los archivos o carpetas seleccionados en el Explorador de Windows.


Copiar el nombre al portapapeles

Esta utilidad copia al portapapeles el nombre de todos los archivos o carpetas seleccionados en el Explorador de Windows.


Copiar contenido al portapapeles

Esta utilidad copia el contenido de un archivo o de una carpeta al portapapeles de Windows. Si se selecciona un archivo, se copiará su contenido, y si se selecciona una carpeta se introducirá en el portapapeles una lista con el nombre de todos los archivos y subcarpetas que contiene la carpeta.


Pegar portapapeles

Esta utilidad pega el contenido del portapapeles al final de los archivos seleccionados. Si hay alguna carpeta seleccionada, entonces se creará un nuevo archivo en esa carpeta con el contenido del portapapeles.

Esta utilidad sólo funciona con archivos de texto y con portapapeles que contenga sólo texto.


Atributos

Esta utilidad permite ver y cambiar los atributos de los archivos o carpetas seleccionados en el Explorador de Windows. Esta utilidad consiste en un submenú que se añade al menú contextual y que muestra una opción por cada atributo que tenga el archivo. Los atributos que se pueden cambiar son:

· Sólo lectura. Indica que el archivo es de sólo lectura, y por lo tanto no se puede cambiar su contenido.
· Oculto. Indica que el archivo está oculto y por lo tanto permanecerá oculto en el Explorador de Windows (a no ser que se haya configurado para que muestre los archivos ocultos).
· Sistema. Indica que es un archivo del sistema.
· Modificado. Indica si el archivo fue modificado después de su creación.

Si una determinada opción está activada, la opción en el submenú aparecerá con un a.

Si el elemento seleccionado en el Explorador de Windows es una carpeta, además habilitará la opción Cambiar recursivamente, el cual permite cambiar un atributo recursivamente en todos los archivos y subcarpetas que contenga la carpeta seleccionada.


Cambiar fecha

Esta utilidad permite cambiar la fecha y hora de creación, modificación y último acceso de los archivos seleccionados en el Explorador de Windows.

Para cambiar una determinada fecha, active la casilla de verificación de su izquierda y edite los campos de la fecha y de la hora que desee cambiar. Puede cambiar con el teclado todos los campos de la fecha y de la hora (día, mes, año, horas, minutos y segundos). También puede utilizar un calendario desplegable para cambiar la fecha.

Si la casilla de verificación que hay a la izquierda de una fecha no se activa, la fecha correspondiente no se cambiará.

Si activa la casilla de verificación Cambiar recursivamente por todos los subdirectorios, las fechas se cambiarán recursivamente en todos los archivos y subcarpetas que contienen las carpetas seleccionadas en el Explorador de Windows.


Dividir/Unir archivo

Esta utilidad permite dividir un archivo en varias partes.

Desde la ventana que aparece se puede elegir el tamaño de cada parte y la carpeta de destino. También es posible comprimir el archivo a dividir para que se creen menos partes. Para ello puede activar la opción Comprimir.

Si antes de dividir el archivo, desea saber cuántas partes se crearán, puede pulsar el botón con el icono CalcularDividir. Tenga en cuenta que si activa la opción Comprimir, el cálculo del número de partes depende de cuánto ocupe el archivo comprimido, por lo tanto se tiene que hacer primero la compresión del archivo para calcular el número de partes. Si el archivo es muy grande este proceso puede ser más o menos largo.

La primera parte del archivo se creará con la extensión .prt y el resto se crearán con una extensión de la secuencia .p01, .p02, .p03, y así sucesivamente según las partes que se necesite crear. El nombre de estos archivos será el mismo que el archivo original sin la extensión.

Para volver a crear el archivo original a partir de sus partes, seleccione el archivo con extensión .prt y en el menú contextual elija la opción Unir las partes.


Registrar/Desregistrar DLL

Esta utilidad permite registrar o desregistrar una DLL o control OCX. Hay algunos componentes de Windows incluidos en una DLL o en un OCX que necesitan registrarse para que las aplicaciones puedan utilizarlos.


 Buscar o reemplazar

Buscar o reemplazar

Esta utilidad permite buscar o reemplazar un texto recursivamente entre todos los archivos y carpetas seleccionados en el Explorador de Windows.

Buscar un texto

Para buscar un texto, introduzca el texto que desea buscar y los tipos de archivos donde desea buscar, y pulse el botón Buscar. Entonces se empezará a buscar el texto entre todos los archivos seleccionados en el Explorador de Windows; y si estuviese activada la opción Entrar en todas las subcarpetas también se buscará en todos los archivos que contengan las carpetas seleccionadas en el Explorador. Cuando termina la búsqueda se mostrará en la parte derecha de la ventana una lista con todas las líneas de cada archivo que contienen el texto de la búsqueda. En esta lista se muestra el archivo que contiene la línea, el número de línea y el texto que contiene la línea. Si hace doble click en una de las líneas de un archivo, se abrirá el archivo con el programa asociado.

Reemplazar un texto por otro

Para reemplazar un texto por otro, introduzca el texto que desea buscar, el texto a reemplazar, y los tipos de archivo donde desea buscar, y pulse el botón Reemplazar. Entonces se empezará el reemplazado del texto entre todos los archivos seleccionados en el Explorador de Windows; y si estuviese activada la opción Entrar en todas las subcarpetas, también se reemplazará en todos los archivos que contengan las carpetas seleccionadas en el Explorador. Cuando termina el reemplazo se mostrará en la parte derecha de la ventana una lista con todas las líneas de cada archivo que han sido reemplazadas. En esta lista se muestra el archivo que contiene la línea, el número de línea y el texto que contiene la línea. Si hace doble click en una de las líneas, se abrirá el archivo con el programa asociado.

También es posible reemplazar un texto sólo en determinadas líneas de archivos buscados anteriormente. Para ello, una vez hecha una búsqueda, se debe seleccionar las líneas a reemplazar en la lista de la parte derecha y pulsar el botón Sólo reemplazar las líneas seleccionadas. Al hacer esto, el texto sólo será reemplazado en las líneas seleccionadas.

Abrir y guardar los resultados de las búsquedas

Después de terminar la búsqueda o el reemplazo, los resultados son mostrados en una lista que aparece en la parte derecha de la ventana. En esta lista se muestra el nombre del archivo, el nº de línea donde se ha buscado o reemplazado el texto y la línea en sí. Es posible guardar estos resultados a un archivo pulsando en el enlace Guardar resultados. Si posteriormente desea volver a recuperar unos resultados guardados anteriormente puede pulsar en el enlace Abrir resultados.

Opciones

Las opciones que se pueden configurar son:

· Distinguir entre Mayúsculas/Minúsculas. Si se activa esta opción, se hará distinción entre los caracteres en mayúsculas y los caracteres en minúsculas al buscar el texto entre los archivos. Si no se activa la opción se buscarán indistintamente los caracteres en mayúsculas y en minúsculas.
· Sólo palabras enteras. Si se activa esta opción, sólo se buscará las palabras que estén separadas por espacios o caracteres separadores.
· Utilizar expresiones regulares. Si se activa esta opción, se podrá utilizar expresiones regulares para las búsquedas.
· Entrar en todas las subcarpetas. Si se activa esta opción, se buscará (o reemplazará) recursivamente entre todos los archivos que contienen las carpetas seleccionadas en el Explorador de Windows. Si no se activa la opción se buscará sólo entre todos los archivos seleccionados en el Explorador y no se tendrán en cuenta las carpetas seleccionadas.
· Copia de seguridad en el directorio "frm_bak". Si se activa esta opción, cuando se vaya a reemplazar un texto en un archivo, se hará una copia de seguridad del archivo original en una subcarpeta llamada frm_bak. Esta subcarpeta estará en la misma carpeta donde esté el archivo a reemplazar.

Perfiles

Si una determinada configuración de búsqueda/reemplazo la utiliza muy a menudo, es posible guardar toda la configuración en perfiles para posteriormente poderla recuperar rápidamente. Los perfiles se gestionan en el panel que está en la parte inferior-izquierda de la ventana. Es posible que el panel aparezca contraido, si fuese así puede desplegarlo pulsando sobre el título del panel.

Para guardar la configuración actual en un perfil pulse en el enlace Guardar perfil. Se le solicitará el nombre del perfil y cuando pulse el botón Aceptar el perfil será añadido en la lista desplegable que hay en el panel de perfiles. Para cargar un perfil existente, selecciónelo de la lista desplegable y pulse en el enlace Cargar perfil. Si desea eliminar un perfil, selecciónelo en la lista desplegable y pulse en el enlace Eliminar perfil.


Renombrado masivo

Esta utilidad permite renombrar de forma automática y a la vez a todos los archivos seleccionados en el Explorador de Windows. Desde las dos primeras pestañas de la ventana de Renombrado masivo se pueden configurar distintas opciones de renombrado. Y en la tercera pestaña (Vista preliminar) se puede ver cómo será el renombrado final de cada archivo.

Opciones básicas

Desde la pestaña Opciones básicas se puede configurar distintos parámetros para cambiar el nombre y/o la extensión de los archivos. Hay dos grupos de opciones, uno para cambiar el nombre y otro para cambiar la extensión. La configuración para ambos casos es similar.

En el campo Cadena se debe indicar un texto y en el campo Situación se debe indicar donde será situado dicho texto. Hay tres posibilidades: reemplazar el texto por el nombre/extensión antiguo, situar el texto delante del nombre/extensión antiguo o situar el texto detrás del nombre/extensión antiguo. También es posible añadir después del texto una secuencia. Para ello hay que indicar el primer elemento de la secuencia, y a partir de ese primer elemento se irá creando el resto de elementos de la secuencia de forma consecutiva. Es posible indicar tanto números como letras. Por ejemplo: si se indica 001, la secuencia consistiría en 001, 002, 003, 004, etc; o si se indica 0A, la secuencia consistiría en 0A, 0B, 0C, etc.

Si desea convertir todas las letras del nombre o de la extensión a minúsculas, a mayúsculas, o la primera letra en mayúsculas y el resto a minúsculas, puede activar la opción Convertir a y especificar el tipo de conversión.

Opciones avanzadas

Desde la pestaña Opciones avanzadas se puede insertar o reemplazar un texto dentro del nombre o de la extensión de los archivos. En el campo Aplicar a puede indicar si los cambios afectarán al nombre, a la extensión o a ambos.

· Insertar. Indique en el campo Cadena el texto que desea insertar y elija donde se insertará ese texto. Puede especificar una posición (empezando en 0), que el texto se inserte antes de una determinada cadena o que el texto se inserte después de una determinada cadena.
· Reemplazar. Hay dos opciones de reemplazo:
· Eliminar la subcadena comprendida entre una posición y otra dentro del nombre/extensión origen e insertar en su lugar el texto que se indique en Cambiar por.
· Reemplazar el texto que se especifique en Buscar la cadena por el texto que se indique en Cambiar por. Si se activa la opción Utilizar expresiones regulares se podrán hacer búsquedas y reemplazos utilizando expresiones regulares.

Si desea que al buscar el texto se distinta entre mayúsculas y minúsculas active la opción Distinguir entre Mayúsculas/Minúsculas.

Vista preliminar

En el panel de la parte derecha hay una lista con dos columnas. En la primera columna se encuentra la lista de archivos con el nombre original y en la segunda columna se puede ver cómo quedarán los archivos una vez renombrados. Esta lista se actualiza automáticamente cuando se cambia algún parámetro de renombrado.

En la lista se puede mover los archivos de posición simplemente arrastrándolos con el ratón de una posición a otra. Esto permite ordenar los archivos adecuadamente para el caso de que se haya configurado una secuencia para el nombre o para la extensión.

Si no desea renombrar uno o varios archivos, seleccione estos archivos en la lista y pulse la tecla suprimir.


Cambiar icono

Esta utilidad permite cambiar el icono de una carpeta. Normalmente todas las carpetas tienen el mismo icono en el Explorador de Windows, pero hay algunas carpetas especiales que tienen otro icono, como por ejemplo las carpetas de Mis documentos y las carpetas de Mis imágenes. Para poner un icono a cualquier carpeta del disco duro se puede utilizar esta utilidad de FileMenu Tools.

Si desea poner el icono por defecto de una carpeta seleccione la opción Icono por defecto y si quiere poner cualquier otro icono que usted desee elija la opción Otro icono. Para elegir el icono pulse sobre el botón BotonExplorar. Entonces se mostrará una ventana donde se puede explorar el sistema de archivos para seleccionar el icono que desee. Se puede elegir un icono que esté en un archivo de alguno de los siguientes tipos: ico, icl, exe, dll, y scr.


Borrado extendido

Esta utilidad permite eliminar archivos que pertenezcan a unos determinados tipos de archivos. Esto puede ser útil para eliminar por ejemplo archivos temporales.

Hay dos posibles opciones para eliminar los archivos según su tipo:

· Eliminar los archivos que cumplan los filtros. Ejemplo: para eliminar todos los archivos con extensión tmp y dat, habría que poner en el campo filtros "*.tmp;*.dat".
· Eliminar los archivos que no cumplan los filtros. Ejemplo: para eliminar todos los archivos menos los que tengan la extensión txt, habría que poner en el campo filtros "*.txt".

Los filtros tienen que estar separados por puntos y comas, y cada filtro puede contener los caracteres comodín * (cualquier número de caracteres) y ? (un sólo carácter). Por ejemplo: el archivo "prueba.txt" cumple el filtro "*.txt", pero no cumple el filtro "*.tmp".

Pulsando en el botón Buscar se realiza una búsqueda de todos los archivos que cumplan o no los filtros (según la opción elegida) y se muestran en una lista. Puede eliminar los archivos seleccionados en esta lista pulsando en el botón Eliminar seleccionados.

Pulsando en el botón Buscar y eliminar se busca y elimina inmediatamente los archivos. En este caso se mostrarán en la lista todos los archivos eliminados.

Opciones

· Buscar en subcarpetas. Active esta opción si desea que se elimine recursivamente por todas las subcarpetas.
· Mover a la papelera. Active esta opción si desea que, en lugar de eliminar los archivos definitivamente, se muevan a la Papelera de Reciclaje. Esta opción sólo tendrá efecto si la papelera de reciclaje de Windows está activada.


Sincronizar dos carpetas

Esta utilidad permite sincronizar dos carpetas. Desde el Explorador de Windows seleccione una de las dos carpetas y en el menú contextual elija Sincronizar con. Al hacer esto se mostrará la siguiente ventana:

Desde el campo Carpeta 2, indique la otra carpeta con la que desea sincronizar. También puede elegir los tipos de archivos que desea sincronizar y el tipo de sincronización que desea realizar en cada carpeta.

Una vez que haya configurado las distintas opciones, pulse el botón Siguiente. Al hacer esto se buscarán los cambios que hay que realizar a las dos carpetas y cuando termine este proceso aparecerá una ventana donde se mostrarán los cambios que se realizarán en cada carpeta.

Según los cambios que se realizarán, los iconos de las carpetas y de los archivos pueden aparecer de distintos colores.

· Verde: archivos y carpetas que se añadirán.
· Rojo: archivos y carpetas que se eliminarán.
· Azul: archivos y carpetas que se reemplazarán.

Si no desea que se aplique un determinado cambio, puede seleccionar el archivo/carpeta y pulsar el botón Quitar cambio.

Cuando desee que se realice el proceso de sincronización, pulse el botón Aceptar.

Tipos de sincronización

Puede especificar cuatro tipos de sincronización:

· Unidireccional, Carpeta1 -> Carpeta2. Seleccionando esta opción se comparará el contenido de las dos carpetas y se reflejará en la Carpeta 2 los cambios que haya en la Carpeta 1. Concretamente se harán los siguientes cambios en la Carpeta 2:
· Se añadirán los archivos o carpetas que existan en la Carpeta 1 pero no en la Carpeta 2.
· Se reemplazarán los archivos que existan en las dos carpetas y que en la Carpeta 1 sean más nuevos que en la Carpeta 2.
· Se eliminarán los archivos o carpetas que existen en la Carpeta 2 pero no en la Carpeta 1.
· Unidireccional, Carpeta1 <- Carpeta2. Seleccionando esta opción se comparará el contenido de las dos carpetas y se reflejará en la Carpeta 1 los cambios que haya en la Carpeta 2. Concretamente se harán los siguientes cambios en la Carpeta 1:
· Se añadirán los archivos o carpetas que existan en la Carpeta 2 pero no en la Carpeta 1.
· Se reemplazarán los archivos que existan en las dos carpetas y que en la Carpeta 2 sean más nuevos que en la Carpeta 1.
· Se eliminarán los archivos o carpetas que existen en la Carpeta 1 pero no en la Carpeta 2.
· Bidireccional, Carepta1 <-> Carepta2. Seleccionando esta opción se comparará el contenido de las dos carpetas y se reflejará en cada carpeta los cambios que haya en la otra. Concretamente se harán los siguientes cambios:
· Se añadirán en la Carpeta 1 los archivos o carpetas que existan en la Carpeta 2 pero no en la Carpeta 1.
· Se añadirán en la Carpeta 2 los archivos o carpetas que existan en la Carpeta 1 pero no en la Carpeta 2.
· Se reemplazarán en la Carpeta 1 los archivos que existan en las dos carpetas y en la Carpeta 2 sean más nuevos que en la Carpeta 1.
· Se reemplazarán en la Carpeta 2 los archivos que existan en las dos carpetas y en la Carpeta 1 sean más nuevos que en la Carpeta 2.
· Personalizado. Seleccionando esta opción es posible configurar qué cambios se tendrán en cuenta en cada carpeta para realizar la sincronización. En el panel de la parte inferior puede activar o desactivar las opciones que desee.

Tipos de archivos a sincronizar

Si lo desea, puede sincronizar solamente algunos archivos que cumplan unos determinados filtros. Desde la lista desplegable Archivos a sincronizar se puede elegir entre tres opciones:

· Todos los archivos. Esta opción copiará o moverá recursivamente todos los archivos y carpetas.
· Sólo los que cumplan los filtros. Si se selecciona esta opción se sincronizarán solamente los archivos que cumplan los filtros que se indiquen en el campo Filtros.
· Todos los que cumplan los filtros. Si se selecciona esta opción se sincronizarán todos los archivos excepto aquellos que cumplan los filtros que se indiquen en el campo Filtros.

El campo Filtros debe contener una lista de filtros (cada uno separado por un punto y coma). Cada filtro puede contener los caracteres comodines * (cero o varios caracteres de cualquier tipo) o ? (un carácter de cualquier tipo). Por ejemplo, para que el filtro lo cumplan los archivos con extensión exe o con extensión dll, se tendría que utilizar el siguiente filtro: *.exe;*.dll.

Perfiles de configuración

Es posible configurar distintos perfiles de configuración para no tener que estar configurando cada vez los distintos parámetros de sincronización entre dos carpetas. En la parte inferior de la ventana hay una lista desplegable con los perfiles disponibles y varios botones que permiten guardar, cargar o eliminar perfiles. En los perfiles se incluye toda la configuración excepto la Carpeta 1 (que será siempre elegida desde el Explorador de Windows).


Eliminar archivo bloqueado

Eliminar archivos bloqueados

Esta utilidad permite eliminar archivos bloqueados por el sistema. A veces hay archivos que no se pueden eliminar porque están siendo usados por alguna aplicación y por lo tanto están bloqueados por el sistema para que no se puedan eliminar. Esta utilidad permite marcar este tipo de archivos para que sean eliminados en el próximo reinicio de Windows antes de que cualquier aplicación pueda bloquearlos.


Eliminar sin usar la papelera

Esta utilidad permite eliminar archivos y/o carpetas sin moverlos a la papelera de reciclaje. De este modo los archivos no ocuparán espacio en el disco duro aunque tampoco habrá forma de poderlos recuperar en un futuro (a no ser que se utilice un programa especial que recupere archivos eliminados).

NOTA: También es posible eliminar archivos sin moverlos a la papelera de reciclaje si se pulsa la tecla SHIFT, a la vez que se pulsa la tecla DEL o se selecciona el comando Delete en el menú contextual.


Destruir archivos

Esta utilidad permite destruir los archivos seleccionados de forma definitiva para que sea imposible recuperarlos con herramientas de recuperación. Cuando se elimina un archivo mediante el procedimiento habitual, sólo se elimina la referencia al archivo, pero no su contenido. Por lo tanto, utilizando herramientas de recuperación de archivos es posible encontrar en disco los archivos que fueron eliminados y recuperar su referencia para que puedan estar otra vez disponibles. Con archivos realmente sensibles esto puede ser un inconveniente. Esta utilidad se encarga de sobreescribir hasta tres veces el contenido del archivo para que de esta forma sea imposible recuperarlo en el futuro.


Crear nueva carpeta

Esta utilidad permite crear una nueva subcarpeta sobre la carpeta seleccionada en el Explorador de Windows.

Esta utilidad sólo se muestra cuando se selecciona una carpeta.


Tamaño de las carpetas

Esta utilidad permite mostrar el tamaño de las carpetas. Si se selecciona una carpeta en el Explorador de Windows, entonces se mostrará el tamaño de las subcarpetas; y si se seleccionan varias carpetas, entonces se mostrará el tamaño de esas carpetas.

La ventana que se muestra tiene el siguiente aspecto:

En la lista de la parte superior se muestra el tamaño de cada carpeta y el porcentaje con respecto al tamaño de todas las carpetas. Debajo se muestra el tamaño total de todas las carpetas y en la parte inferior de la ventana se muestra un gráfico que detalla de forma visual el porcentaje de cada carpeta.

Si hace doble click sobre una carpeta de la lista, se analizará el tamaño de todas sus subcarpetas. Si pulsa sobre el botón BotonSubirNivel, se analizará el tamaño de las subcarpetas de la carpeta padre.


 Comandos personalizados

Comandos personalizados

FileMenu Tools permite configurar comandos personalizados que se añadirán al menú contextual que aparece al hacer click con el botón derecho del ratón desde Explorador de Windows sobre los elementos seleccionados. Hay cuatro tipos de comandos personalizados que permiten realizar distintas acciones sobre los elementos seleccionados. Estas acciones son las siguientes:

· Ejecutar un programa externo, pasándole como parámetros los archivos seleccionados.
· Copiar los elementos seleccionados a una determinada carpeta.
· Mover los elementos seleccionados a una determinada carpeta.
· Eliminar determinados archivos dentro de las carpetas seleccionadas.

Desde la pestaña Comandos de FileMenu Tools de la ventana de configuración de FileMenu Tools se puede añadir nuevos comandos, eliminarlos y cambiar sus propiedades.

Para añadir un nuevo comando pulse el botón Agregar comando. El nuevo comando aparecerá en la lista con el nombre "Nuevo comando".

Para cambiar la configuración de un nuevo comando o de un comando existente se debe utilizar el panel de propiedades. Hay propiedades comunes a todos los comandos y propiedades específicas para cada tipo de comando.

Propiedades comunes a todos los tipos de comandos

· Acción. La acción que debe realizar el comando: ejecutar programa, copiar a una carpeta, mover a una carpeta o eliminar determinados archivos.
· Texto en el menú. El texto que debe aparecer en el menú para identificar el comando.
· Icono. El icono que debe aparecer en el menú. Pulsando sobre el botón con puntos suspensivos que hay en la parte derecha se mostrará un cuadro de diálogo para elegir el icono.
· Tipos de elementos. El comando sólo aparecerá en el menú cuando alguno de los elementos seleccionados en el Explorador de Windows sea de alguno de estos tipos. Los tipos de elementos pueden ser carpetas y/o archivos. En el caso de elegir archivos, se deberá indicar las extensiones de los tipos de archivos separadas por una coma; con un * se indica todos los tipos de archivos. Por defecto todos los comandos son mostrados cuando hay varios archivos seleccionados, pero si desea que sólo se muestre cuando hay un solo elemento seleccionado, entonces ponga a "Sí" la opción "Un solo elemento".

Propiedades para programas externos

· Programa. El programa que se debe ejecutar. Se debe indicar la ruta completa del archivo ejecutable.
· Argumentos. Los argumentos que se debe pasar al programa. Si no se pone nada en este campo, por defecto se le pasarán al programa todos los archivos seleccionados en el Explorador de Windows. Se puede añadir varias variables que serán sustituidas por su valor en el momento de ejecutar el programa. Para añadir una variable pulse en el botón que hay en la parte derecha y en el menú elija la variable que desee añadir. Las posibles variables son:
· %DRIVE%: letra de unidad común a todos los archivos seleccionados.
· %FOLDERPATH%: carpeta padre común a todos los archivos seleccionados.
· %FILEPATHS%: rutas completas de todos los archivos seleccionados. Esta será la variable por defecto que se utilizará en el caso de que no se indique ningún argumento.
· %FILENAMES%: nombres de todos los archivos seleccionados.
· %FILEPATHn%: ruta completa del archivo en la posición n.
· %FILENAMEn%: nombre del archivo en la posición n.
· %FILEEXTn%: extensión del archivo en la posición n.
· @Mensaje@: se solicitará el valor de la variable en el momento de ejecutar el comando. Para ello se muestra una ventana de diálogo donde se debe introducir el valor de la variable. Mensaje debe ser el texto que se mostrará en la ventana de diálogo.
· @OPENFILE:Mensaje@: el valor de la variable es la ruta de un archivo que se debe seleccionar en el momento de ejecutar el comando. Para ello se muestra una ventana de diálogo para buscar el archivo en el sistema de ficheros. Mensaje debe ser el texto que se mostrará en el cuadro de diálogo.
· @SAVEFILE:Mensaje@: el valor de la variable es la ruta de un archivo que se debe seleccionar en el momento de ejecutar el comando. Para ello se muestra una ventana de diálogo para buscar el archivo en el sistema de ficheros. Mensaje debe ser el texto que se mostrará en el cuadro de diálogo.
· @FOLDER:Mensaje@: el valor de la variable es la ruta a una carpeta que se debe seleccionar en el momento de ejecutar el comando. Para ello se muestra una ventana de diálogo para buscar la carpeta en el sistema de ficheros. Mensaje debe ser el texto que se mostrará en el cuadro de diálogo.
· Carpeta inicial. La carpeta inicial desde la que se debe ejecutar el programa. Se pueden especificar varias variables que serán sustituidas por su valor en el momento de ejecutar el programa. Para insertar una variable elija la opción correspondiente del menú que sale al pulsar el botón de la parte derecha. Las variables que se pueden especificar son:
· %DRIVE%: letra de unidad común a todos los archivos seleccionados.
· %FOLDERPATH%: carpeta padre común a todos los archivos seleccionados.

Propiedades para copiar/mover a una determinada carpeta

· Carpeta de destino. La carpeta donde deben copiarse/moverse los archivos.
· Tipos de archivos. Los tipos de archivos que se deben copiar/mover. Se puede elegir: todos los archivos, sólo los archivos que cumplan los filtros o sólo los archivos que no cumplan los filtros. En las dos últimas opciones se debe indicar los filtros de los tipos de archivos.
· Sobreescribir. Si se elige "Sí", al copiar un archivo que exista en el directorio de destino, será sobreescrito automáticamente sin preguntar; en otro caso, se solicitará confirmación para sobreescribir el archivo.

Propiedades para eliminar determinados archivos

· Tipos de archivos. Los tipos de archivos que deben ser eliminados.
· Entrar en subcarpetas. Indica si se debe entrar recursivamente en todas las subcarpetas para eliminar los archivos.
· Mover a la papelera. Indica si se debe mover a la papelera los archivos en lugar de eliminarlos. Esta opción sólo tendrá efecto si la papelera de reciclaje de Windows está activada.


 Menú Enviar a...

Menú Enviar a...

FileMenu Tools permite configurar los programas que aparecen en el submenú Enviar a... del menú contextual del Explorador de Windows. Se puede añadir nuevos programas, cambiar las propiedades de los programas existentes y eliminarlos. También se puede deshabilitar (sin necesidad de eliminar) los programas existentes.

La configuración del submenú Enviar a... se hace desde la pestaña Menú "Enviar a..." de la ventana de configuración de FileMenu Tools.

Para añadir nuevos programas al submenú Enviar a..., pulse el botón Agregar comando.

Para eliminar un programa existente, seleccione el programa en la lista y pulse el botón Eliminar.

Para ocultar un programa y que éste no aparezca en el menú contextual, desactive la casilla de verificación que hay a la izquierda del elemento.

Para cambiar las propiedades de un nuevo programa o de un programa ya existente, seleccione el programa en la lista y cambie las propiedades desde el panel de propiedades. Las propiedades que se puede modificar son las siguientes:

· Nombre. El texto que aparecerá en el menú contextual.
· Programa. El programa que se debe ejecutar. Se debe indicar la ruta completa del archivo ejecutable.
· Argumentos. Los argumentos que se pasarán al programa.
· Carpeta inicial. La carpeta inicial desde la que se ejecutará el programa.
· Icono. El icono que aparecerá en el menú. Pulsando el botón de la derecha se mostrará una ventana de diálogo para seleccionar el archivo que contiene el icono. Se puede elegir un icono de un archivo .ico o un icono que esté en una librería de iconos (archivos .exe, .dll, .icl).
· Descripción. Un comentario sobre el programa.

NOTA: hay comandos especiales en el menú Enviar a... a los que no es posible cambiarles la configuración. En este tipo de comandos el panel de propiedades aparecerá vacío y por lo tanto no se permitirá cambiar las propiedades.


Comandos de otros programas

FileMenu Tools permite habilitar/deshabilitar los comandos que añaden otros programas al menú contextual del Explorador de Windows.

La configuración se realiza desde la pestaña Comandos de otros programas de la ventana de configuración de FileMenu Tools.

Hay un arbol de dos niveles. En el primer nivel se encuentran los tipos de objetos del sistema, y en el segundo nivel se encuentran los programas que añaden comandos al menú contextual cuando se selecciona un objeto cuyo tipo corresponde al del primer nivel. Dependiendo de la versión de Windows, se mostrarán unos tipos de objetos u otros. Los tipos de objetos podrían ser como los siguientes:

· Todos los tipos de archivos y carpetas. En este caso, los programas o comandos que cuelguen de este nodo se mostrarán siempre cuando los objetos seleccionados sean archivos o carpetas.
· Todos los objetos del sistema. En este caso, los programas o comandos se mostrarán siempre.
· Unidades.
· Directorios.
· Carpetas.
· Accesos directos.
· Accesos directos a una URL de Internet.
· Accesos directos a un programa MS-DOS.
· Papelera de reciclaje.
· Impresoras.
· Mis documentos.

Para deshabilitar un programa o comando, simplemente hay que desactivar la casilla de verificación que hay a la izquierda, y para volverlo a habilitar hay que activar la casilla de verificación.


.topic 1004
El panel de propiedades de la ventana de configuración de FileMenu Tools permite cambiar las propiedades del elemento seleccionado. Normalmente este panel se encuentra en la parte inferior-izquierda de la ventana. Para mostrar este panel hay que pulsar sobre el botón &quot;Propiedades&quot; o ejecutar el comando de menú &quot;Editar/Propiedades&quot;.
.topic 1002
Los tipos de archivos se especifican mediante filtros que contienen los caracteres comodín * (cualquier número de caracteres de cualquier tipo) y ? (cualquier carácter). Los distintos filtros tienen que estar separados por un punto y coma.
Ejemplo: *.htm;*.html


Expresiones regulares

 Top

FileMenu Tools utiliza la sintaxis de expresiones regulares del lenguaje de programación Perl. Con las expresiones regulares se pueden definir patrones de búsqueda y reemplazo. Este mecanismo proporciona una gran potencia cuando se quiere buscar y/o reemplazar un texto.

En esta sintaxis todos los caracteres tienen concordancia en sí mismos excepto para los siguientes caracteres especiales:

.[]{}()\*+?|^$

Si se desea utilizar alguno de los caracteres anteriores como literales hay que anteponerle el carácter \. Por ejemplo, si se desea utilizar el carácter ? como literal, habrá que indicarlo con \?, sino se hace así el carácter ? se interpretará como un operador y por lo tanto el comportamiento no sería el deseado.

Carácter comodín

El carácter '.' concuerda con cualquier carácter, excepto el carácter de nueva línea y retorno de carro.

Inicio y final de línea

El carácter ^ concuerda con el inicio de línea, es decir, si se incluye este carácter al inicio del patrón de búsqueda, la búsqueda se producirá sólo al principio de las líneas.

El carácter $ concuerda con el final de línea, es decir, si se incluye este carácter al final del patrón de búsqueda, la búsqueda se producirá sólo al final de las líneas.

Definición de sub-expresiones

Una sección que empieza con ( y termina con ) actúa como una sub-expresión. Las sub-expresiones utilizadas en el patrón de búsqueda son almacenadas en un registro y pueden ser posteriormente referenciadas en el propio patrón de búsqueda o al reemplazar. Para referenciar una sub-expresión se debe utilizar \n, donde n es el índice de la sub-expresión (entre 1 y 9).

Agrupación sin definir sub-expresiones

La definición de una sub-expresión es útil para agrupar parte de una expresión regular, pero tiene el resultado de crearse un nuevo registro para su uso posterior. Como alternativa se puede crear una agrupación en una expresión regular pero sin generar una sub-expresión usando (?: y ). Por ejemplo (?:ab)+ repetirá "ab" sin generar una sub-expresión separada.

Repeticiones

Cualquier carácter o agrupación puede ser repetida usando los operadores *, +, ? y { }.

El operador * concuerda con cero o más repeticiones de la expresión anterior. Por ejemplo: la expresión a*b concuerda con cualquiera de lo siguiente:

b

ab

aaaaaaaab

El operador + concuerda con uno o más repeticiones de la expresión anterior. Por ejemplo: la expresión a+b concuerda con cualquiera de lo siguiente:

ab

aaaaaaaab

Pero no concuerda con:

b

El operador ? concuerda con cero o una repeticiones de la expresión anterior. Por ejemplo: la expresión ca?b concuerda con cualquiera de lo siguiente:

cb

cab

Pero no concuerda con:

caab

Una expresión puede ser repetida n veces con el operador { }, de la siguiente manera:

· a{n} concuerda con n repeticiones de 'a'.
· a{n,} concuerda con n o más repeticiones de 'a'.
· a{n, m} concuerda con n a m repeticiones de 'a'.

Por ejemplo:

^a{2,3}$

Tiene concordancia con alguna de las siguientes:

aa

aaa

Pero no tiene concordancia con:

a

aaaa

No es posible utilizar un operador de repetición si la expresión anterior no puede ser repetida. Por ejemplo::

a(*)

Se producirá un error y no habrá nada donde aplicar el operador *.

Sustituciones

El carácter de escape seguido por un dígito n, donde n está comprendido entre 1 y 9, concuerda la misma cadena que tenía concordancia por la sub-expresión n. Por ejemplo, la expresión siguiente:

^(a*).*\1$

Tiene concordancia con la cadena:

aaabbaaa

Pero no con la cadena:

aaabba

Las sustituciones también pueden ser utilizadas dentro de las expresiones de reemplazo para cuando se reemplaza un texto.

Alternativa

El operador | concuerda con alguno de los argumentos, por ejemplo: abc|def concordará con "abc" o con "def".

El paréntesis puede ser utilizado para agrupar alternativas, por ejemplo: ab(c|ef) concordará con "abc" o con "abef".

Las alternativas vacías no están permitidas. Si se quiere indicar una alternativa vacía es necesario utilizar la directiva (?:), por ejemplo:

"|abc" no es una expresión válida, pero
"(?:)|abc" sí es válida, al igual que la expresión:
"(?:abc)??" que tiene el mismo efecto.

Colección de caracteres:

Una colección de caracteres es una expresión que comienza con [ y termina con ]. Este tipo de expresión concuerda con cualquier carácter que esté incluido dentro de la colección.

Este tipo de expresiones pueden contener cualquier combinación de lo siguiente:

Caracteres:

Por ejemplo: [abc] concordará con cualquiera de los caracteres 'a', 'b', ó 'c'.

Rango de caracteres:

Por ejemplo: [a-c] concordará con cualquier carácter en el rango 'a' a 'c'.

Negación:

Si una expresión encerrada por corchetes comienza con el carácter ^, entonces concordará con el complemento de los caracteres que contiene. Por ejemplo: [^a-c] concordará con cualquier carácter que no esté en el rango a-c.

Clases de caracteres:

Una expresión de la forma [[:nombre:]] concuerda con la clase de carácter cuyo nombre es "nombre". Por ejemplo: [[:lower:]] concuerda con cualquier carácter en minúsculas. Vea las clases de caracteres que son admitidos.

Símbolos:

Mediante la expresión [[.nombre.]] se puede especificar determinados tipos de caracteres cuyo nombre es "nombre". Por ejemplo, con la expresión [[.NUL.]] se especificaría el carácter nulo. Vea los nombres simbólicos que son admitidos.

Clases de equivalencia:

Una expresión de la forma [[=caracter=]] concuerda con cualquiera de las formas equivalentes del carácter indicado, como por ejemplo las mayúsculas/minúsculas, la tilde o cualquier otra forma específica del idioma. Así, por ejemplo [[=a=]] concuerda con los caracteres: a, à, á, â, ã, ä, å, A, À, Á, Â, Ã, Ä y Å.

Combinaciones:

Todas las formas comentadas anteriormente pueden ser combinadas en una expresión más compleja, por ejemplo: [[:digit:]a-c[.NUL.]].

Secuencias de escape

Cualquier carácter especial precedido por la barra vertical \ concordará consigo mismo. Si por ejemplo se desea utilizar el asterisco como carácter literal y no como operador dentro de la expresión, sería necesario utilizar \*.

Las siguientes secuencias son también soportadas:

Caracteres específicos

Las siguientes secuencias de escape son sinónimos para determinados caracteres:

Escape | Carácter
\a | Timbre (0x07).
\e | Carácter de ESC (0x1B).
\f | Salto de página.
\n | Salto de línea.
\r | Retorno de carro.
\t | Tabulador horizontal.
\v | Tabulador vertical.
\cX | Un carácter ASCII, cuyo código es X % 32.
\xdd | Un carácter ASCII especificado en hexadecimal, cuyo código será 0xdd.
\x{dddd} | Un carácter UNICODE especificado en hexadecimal, cuyo código es 0xdddd.
\0ddd | Un carácter ASCII especificado en octal, cuyo código es 0ddd.
\N{nombre} | Un carácter que coincide con el nombre simbólico "nombre". Por ejemplo: \N{newline} indicará el carácter de salto de línea y por lo tanto sería equivalente a \n.

Clases de caracteres:

Hay determinadas clases de caracteres que tienen su equivalente como una secuencia de escape.

Carácter de escape | Equivalente a
\d | [[:digit:]]
\l | [[:lower:]]
\s | [[:space:]]
\u | [[:upper:]]
\w | [[:word:]]
\D | [^[:digit:]]
\L | [^[:lower:]]
\S | [^[:space:]]
\U | [^[:upper:]]
\W | [^[:word:]]

Propiedades de caracteres

Los nombres de propiedades de la siguiente tabla son equivalentes a los nombres utilizados en las clases de caracteres:

Forma | Descripción | Equivalente a
\pX | Indica cualquier carácter que tiene la propiedad X. | [[:X:]]
\p{Nombre} | Indica cualquier carácter que tiene la propiedad "Nombre". | [[:Nombre:]]
\PX | Indica cualquier carácter que no tiene la propiedad X. | [^[:X:]]
\P{Nombre} | Indica cualquier carácter que no tiene la propiedad "Nombre". | [^[:Nombre:]]

Demarcación de palabras

Las siguientes secuencias de escape indican demarcación de palabras:

\< | Concuerda con el inicio de una palabra.
\> | Concuerda con el final de una palabra.
\b | Concuerda con el inicio y el final de una palabra.
\B | Concuerda sólo cuando no se está en el inicio o el final de una palabra.

Secuencia de literales

La secuencia de escape \Q comienza una secuencia de literales, es decir, todos los caracteres que vengan después serán tratados como literales, hasta que se alcanza el final de la expresión o se especifica la secuencia de escape \E. Por ejemplo, la expresión: \Q\*+\Ea+ concuerda con alguna de las siguientes cadenas:

\*+a
\*+aaa

Cualquier otra secuencia de escape

Cualquier otra secuencia de escape concordará con el carácter indicado. Por ejemplo \@ concordará con el literal '@'.

Extensiones

Todas las extensiones comienzan con (? y finalizan con ).

Comentarios

(?# ... ) es tratado como un comentario, y por lo tanto su contenido será ignorado.

Agrupaciones sin generar sub-expresiones

Una expresión de la forma (?:patrón) permite agrupar patrones sin generar una nueva sub-expresión.

Mirar hacia adelante

(?=patrón) consume cero caracteres sólo si el patrón concuerda.

(?!patrón) consume cero caracteres sólo si el patrón no concuerda.

Este tipo de expresión es utilizada normalmente para crear un AND lógico de dos expresiones regulares, por ejemplo si una contraseña debe contener una letra en minúscula, una letra en mayúscula, un símbolo de puntuación, y debe tener al menos 6 caracteres, entonces la expresión:

(?=.*[[:lower:]])(?=.*[[:upper:]])(?=.*[[:punct:]]).{6,}

puede ser utilizada para validar la contraseña.

Mirar hacia atrás

(?<=patrón) consume cero caracteres sólo si el patrón puede tener concordancia con los caracteres que preceden a la posición actual (el patrón debe ser de longitud fija).

(?<!patrón) consume cero caracteres sólo si el patrón no puede tener concordancia con los caracteres que preceden a la posición actual (el patrón debe ser de longitud fija).

Expresiones condicionales

Una expresión de la forma (?(condición)patrón-sí|patrón-no) intenta concordar patrón-sí si la condición es verdadera, en otro caso intentará concordar la expresión patrón-no.

Una expresión de la forma (?(condición)patrón-sí) intenta concordar patrón-sí si la condición es verdadera, en otro caso falla.

La condición puede ser una aserción hacía adelante, o el índice de una sub-expresión (la condición será verdadera si la sub-expresión ha tenido concordancia).

Precedencia de los operadores

El orden de precedencia (de mayor a menor) para los operadores es el mostrado en la siguiente tabla:

Símbolos, clases de caracteres, y clases de equivalencia | [==] [::] [..]
Secuencias de escape | \
Colección de caracteres | []
Agrupación | ()
Repetición | * + ? {m,n}
Concatenación |
Inicio y final de línea | ^$
Alternación | |


Clases de caracteres

Clases de caracteres en expresiones regulares

 Top

Nombre | Descripción
alnum | Cualquier carácter alfanumérico.
alpha | Cualquier carácter alfabético.
blank | Cualquier espacio en blanco.
cntrl | Cualquier carácter de control.
d | Cualquier dígito decimal.
digit | Cualquier dígito decimal.
graph | Cualquier carácter gráfico.
l | Cualquier carácter en minúsculas.
lower | Cualquier carácter en minúsculas.
print | Cualquier carácter imprimible.
punct | Cualquier carácter de puntuación.
s | Cualquier espacio en blanco.
space | Cualquier espacio en blanco.
unicode | Cualquier carácter extendido cuyo código está por encima de 255.
u | Cualquier carácter en mayúsculas.
upper | Cualquier carácter en mayúsculas.
w | Cualquier carácter perteneciente a una palabra (caracteres alfanuméricos y el carácter de subrayado).
word | Cualquier carácter perteneciente a una palabra (caracteres alfanuméricos y el carácter de subrayado).
xdigit | Cualquier carácter en hexadecimal.


Nombres simbólicos

Nombres simbólicos en expresiones regulares

 Top

Nombre | Carácter
NUL | \x00
SOH | \x01
STX | \x02
ETX | \x03
EOT | \x04
ENQ | \x05
ACK | \x06
alert | \x07
backspace | \x08
tab | \t
newline | \n
vertical-tab | \v
form-feed | \f
carriage-return | \r
SO | \xE
SI | \xF
DLE | \x10
DC1 | \x11
DC2 | \x12
DC3 | \x13
DC4 | \x14
NAK | \x15
SYN | \x16
ETB | \x17
CAN | \x18
EM | \x19
SUB | \x1A
ESC | \x1B
IS4 | \x1C
IS3 | \x1D
IS2 | \x1E
IS1 | \x1F
space | \x20
exclamation-mark | !
quotation-mark | "
number-sign | #
dollar-sign | $
percent-sign | %
ampersand | &
apostrophe | '
left-parenthesis | (
right-parenthesis | )
asterisk | *
plus-sign | +
comma | ,
hyphen | -
period | .
slash | /
zero | 0
one | 1
two | 2
three | 3
four | 4
five | 5
six | 6
seven | 7
eight | 8
nine | 9
colon | :
semicolon | ;
less-than-sign | <
equals-sign | =
greater-than-sign | >
question-mark | ?
commercial-at | @
left-square-bracket | [
backslash | \
right-square-bracket | ]
circumflex | ~
underscore | _
grave-accent | `
left-curly-bracket | {
vertical-line | |
right-curly-bracket | }
tilde | ~
DEL | \x7F